re = /\"(?:\\\"|[^\"])*\"/
str = 'some text "some tetx"
few "text are \\" escaped" "once again"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end