const regex = /(?:'|\G(?!^))\s(?=\s*')'?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\'|\\G(?!^))\\s(?=\\s*\')\'?', 'g')
const str = `vpl_text := to_char(vpl_text_old) || ' ' ||...;
vpl_text := to_char(vpl_text_old) || '' ||...;`;
const subst = `CHR\(32\)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);