import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=^(?:\\+|00)?(?:[\\-\\/\\(\\)]?\\d){11}$)(?:00|\\+)[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])[^\\d]*([\\d])$";
final String string = "+48301234567\n"
+ "+4-8-3-0-1-2-3-4-5-6-7\n"
+ "+48/30/1234567\n"
+ "+48-30-12-345-67\n"
+ "+483011223344556677\n"
+ "0048301234567\n"
+ "+(48)30/1234567";
final String subst = "+(\\1\\2) \\3\\4/\\5\\6-\\7\\8\\9-\\10\\11";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}