import Foundation
let pattern = #"www\w+:\/\/[\w.-]+(?::?\d{1,5})?[-\w.\/?=&%]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://youtube.com/watch?a=r_FgjB-RKNo&u=/watch%3Fv%3DB0_3423
https://localhost:443
mailto://www.domain.com:8080/something
http://www.domain.com/something:badurl
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)