$re = '/\w+\s\d+(st)?(nd)?(rd)?(th)?,\s+\d+/';
$str = '[1] "\\r\\n Washington,\\r\\n Jan 5, 2011"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);