Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
((?:[0-9]{1,3},(?:[0-9]{3},)*[0-9]{3}|[0-9]+)(?:.[0-9][0-9])?)\s*(?:ש\"ח|₪|nis|NIS|שקל)(?:\W|$)
"
g
Input 1
1
New
10,100,000nis 100.00 ש"ח sfdsf sd34 sdf 3.00 nis 5,000 שקל