import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[0-9]{1,3},(?:[0-9]{3},)*[0-9]{3}|[0-9]+)(?:.[0-9][0-9])?)\\s*(?:ש\\\"ח|₪|nis|NIS|שקל)(?:\\W|$)";
final String string = "10,100,000nis \n\n"
+ "100.00 ש\"ח\n"
+ " sfdsf sd34 sdf 3.00 nis\n"
+ "5,000 שקל";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}