import re
regex = re.compile(r"((?:[0-9]{1,3},(?:[0-9]{3},)*[0-9]{3}|[0-9]+)(?:.[0-9][0-9])?)\s*(?:ש\"ח|₪|nis|NIS|שקל)(?:\W|$)")
test_str = ("10,100,000nis \n\n"
"100.00 ש\"ח\n"
" sfdsf sd34 sdf 3.00 nis\n"
"5,000 שקל")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")