import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\\\(.*)\\\\(.*)\\\\(.*?)( \\((\\d{4})\\))?\\\\(\\d+)-(.*)\\.flac$";
final String string = "c:\\Users\\Me\\Music\\FLAC\\Rock\\The Doors\\Strange Days (1967)\\07-People Are Strange.flac";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}