const regex = /.*\\(.*)\\(.*)\\(.*?)( \((\d{4})\))?\\(\d+)-(.*)\.flac$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\\\(.*)\\\\(.*)\\\\(.*?)( \\((\\d{4})\\))?\\\\(\\d+)-(.*)\\.flac$', 'i')
const str = `c:\\Users\\Me\\Music\\FLAC\\Rock\\The Doors\\Strange Days (1967)\\07-People Are Strange.flac`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}