$re = '/[4|3|5]([0-9[:space:]\t]{29,31})|[4|3|5]([0-9\s\S\w+]{28})/';
$str = '312345678901234
3123456789012344
\\s*(?:\\S\\s*)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);