using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:https?:\/\/)?[^\/\s]*\.([^.\s\/]*\.[^.\s\/]*)(?:$|\/.*)";
string substitution = @"$1";
string input = @"http://therealzenstar.blogspot.fr
http://therealzenstar.blogspot.fr/
http://therealzenstar.blogspot.fr/some_test.domain.html
http://therealzenstar.blogspot.co.uk/some_test.domain.html";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}