# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(ebay(\.[a-z]{2,3}){1,2}/(itm|link/\?nav=item))"
test_str = ("SHOULD MATCH\n\n"
"ebay.com/itm\n\n"
"ebay.nl/itm\n\n"
"anything.ebay.co.uk/link/?nav=item\n\n\n"
"SHOULD NOT MATCH\n\n"
"Customer service: http://ocsnext.ebay.com/ocs/home?\n\n"
"Sign in: https://signin.ebay.com/ws/\n\n"
"Privacy policy: http://pages.ebay.com/help/policies/user-agreement.html?rt=nc")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.