using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w'-.]+\w|[\w'-]+\s*";
string input = @"Hey y'all, use T-Mobile & 23andme.com in the U.K.! Thanks.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}