Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
[\w'-.]+\w|[\w'-]+\s*
"
Input 1
1
New
Hey y'all, use T-Mobile & 23andme.com in the U.K.! Thanks.