Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
[\w'-.]+\w|[\w'-]+\s*
"
Test String
New
Hey y'all, use T-Mobile & 23andme.com in the U.K.! Thanks.