using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!zz)(?:(?!zz\b)\w)+zz(?:(?!zz\b)\w)+\b";
string input = @"lorem ipsum buzz mezzo mix zztop but this is all";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}