const regex = /[&?]tags=([^&\n-]*(?:-[^&\n-]+)*)(?:--(\d+))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[&?]tags=([^&\\n-]*(?:-[^&\\n-]+)*)(?:--(\\d+))?', 'g')
const str = `http://localhost:30001/catalog/search?tags=bed-green-big-33-22-ancient-5--2
http://localhost:30001/catalog/search?tags=bed-green-big-33-22-ancient-5
http://localhost:30001/catalog/search?more1=eee&tags=bed-green-big-33-22-ancient-5--4&gh=1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}