$re = '/(?=(\s+))\1(?!$)/';
$str = 'this is a test
';
$subst = "essss";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;