$re = '/^(?m)(?<indent>\s*)describe\(\'([^\']+)\'[^{]+\{([\s\S]+?)\n\k<indent>\}\);/m';
$str = 'describe(\'a jasmine describe\', function (){
it(\'login\', function(){
//some function stuff
});
it(\'another it statement\', function() {
//some additional stuff
});
});
describe(\'a jasmine describe\', function (){
it(\'login\', function(){
//some function stuff
});
it(\'another it statement\', function() {
//some additional stuff
});
});
describe(\'a jasmine describe\', function (){
it(\'login\', function(){
//some function stuff
});
it(\'another it statement\', function() {
//some additional stuff
});
});';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);