import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"title\": \"[^\"]*\"";
final String string = "1. Есть строки в текстовом файле: \"title\": \"разный текст\"\n"
+ "Найти всё в этом файле.\n"
+ "2. Есть строки в текстовом файле:\n"
+ "\"url\": \"разный текст\"\n"
+ "Найти всё в этом файле.\n\n"
+ "3. Есть всё в общей строке в текстовом файле:\n"
+ "\"title\": \"разный текст\", \"url\": \"разный текст\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}