#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:[a-z]{2}|[a-z])\d.*$"
Local $sString = "AB1ghRjh" & @CRLF & _
"c1" & @CRLF & _
"G44" & @CRLF & _
"Tt7688" & @CRLF & _
"kGF98d" & @CRLF & _
"4FG3" & @CRLF & _
"4 5a" & @CRLF & _
"RRFDE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")