import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[a-z]{2}|[a-z])\\d.*$";
final String string = "AB1ghRjh\n"
+ "c1\n"
+ "G44\n"
+ "Tt7688\n"
+ "kGF98d\n"
+ "4FG3\n"
+ "4 5a\n"
+ "RRFDE";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}