$re = '/^(?:[a-z]{2}|[a-z])\d.*$/mi';
$str = 'AB1ghRjh
c1
G44
Tt7688
kGF98d
4FG3
4 5a
RRFDE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);