using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(?i)(?:(?<=^|\s)(?=\S)|(?<=\S|^)(?=\s)){0}(?:(?<=\S)(?=\s|$)|(?<=\s)(?=\S|$))";
        string input = @"ally can be chaallnged {ALL} tested all";
        
        Match m = Regex.Match(input, pattern);
        Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
    }
}