const regex = /(?i)(?:(?<=^|\s)(?=\S)|(?<=\S|^)(?=\s)){0}(?:(?<=\S)(?=\s|$)|(?<=\s)(?=\S|$))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(?:(?<=^|\\s)(?=\\S)|(?<=\\S|^)(?=\\s)){0}(?:(?<=\\S)(?=\\s|$)|(?<=\\s)(?=\\S|$))', '')
const str = `ally can be chaallnged {ALL} tested all`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}