use strict;
my $str = 'Topic one ......... 30 Second Topic .......... 33
Third one ......... 3 Topic.with.dots .......... 33
One more line ......................... 27 last topic ...... 34';
my $regex = qr/(?=[A-Z])(?:\.[A-Z]+|[A-Z\s]+)+\b/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}