re = /^(?i).*(?P<fileExt>\.mka)$/
str = '[TxxZ&A.I.R.nesSub][Library_Wars][The_Last_Mission][BDRIP][1920x1080][HEVC_AC3x2].mka'
# Print the match result
str.match(re) do |match|
puts match.to_s
end