package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^([a-zA-Z][\s\S]*?)\<br\>`)
var str = `Лорем ипсум<br>привет мир<br>голактеко опасносте<br>Лорем ипсум<br>
Lorem ipsum dolor <a href="">sit</a> amet, consectetur adipisicing elit.<br>
<br>
<img src="img.jpg" alt="">
<br>
Lorem ipsum dolor sit amet, consectetur <a href="">adipisicing</a> elit.<br>
<br>
<div class="inner">Lorem ipsum dolor sit amet, consectetur adipisicing elit. Impedit, voluptas.</div>
<br>
Lorem ipsum <span>dolor</span> sit amet, consectetur adipisicing elit.<br>
<br>
<div>
<img src="img.jpg" alt="">
</div>
<br>
Lorem <b>ipsum</b> dolor sit amet, consectetur adipisicing elit.<br>
<br>
<div>Lorem...</div>
<br>
Lorem ipsum dolor sit amet, consectetur adipisicing elit.<br>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}