re = /^([a-z\d]+)(([A-Z\d]+)*([a-z\d]+)*)*$/m
str = 'myVar
my2varBaz
myVar2
myVar2
myVAR2baz
myvar
myVAR
myVarAndV
myVARandV
xmlHTTPRequest
XMLHttpRequest
MYVAR
my-var
Myvar
my_var
myV_ar
my_Var'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end