import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<w:p[^>]+>(?:(?!<\\/wp>).)+?<\\/w:p>)";
final String string = "<w:p>\n"
+ " Some Other XML\n"
+ " <w:p someatribute=\"something\">\n"
+ " HERE\n"
+ " </w:p>\n"
+ " Some Other XML\n"
+ "</w:p>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}