$re = '/(<w:p[^>]+>(?:(?!<\/wp>).)+?<\/w:p>)/s';
$str = '<w:p>
Some Other XML
<w:p someatribute="something">
HERE
</w:p>
Some Other XML
</w:p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);