$re = '/(one|two|three);?(?!\1)(one|two|three);?(?!\2)(one|two|three)/m';
$str = 'one;two;three
two;one;three
three;two;one
one;one;two
three;one;two
onetwothree
two;one;one';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);