const regex = /(?<=\/|<)(\w{4,})(?=>)|\b(\w{4,})/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\\/|<)(\\w{4,})(?=>)|\\b(\\w{4,})', 'gs')
const str = `Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor
invidunt ut labore et dolore <strong>magna aliquyam erat</strong>, sed diam voluptua.
Lorem ipsum dolor sit amet, consetetur sadipscing elitr, sed diam nonumy eirmod tempor
invidunt ut labore et dolore <strong>magna</strong> aliquyam erat, sed diam voluptua <lol>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);