import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Source_addresses:(?:.|\\n)*?Applications:.*\\n)";
final String string = "Policy name: example-3 (lf-csd) (LINE 29907)\n\n"
+ " Description: CHANGE00001\n"
+ " Destination_addresses (8):\n"
+ " 10.0.0.1/32 ( 10.0.0.1-lk-3r53) ( 3125)\n"
+ " 10.0.0.8/32 ( 10.0.0.8-test13) ( 3157)\n"
+ " 10.0.0.3/32 ( 10.0.0.3-gdgsd-cd) ( 2806)\n"
+ " 10.0.0.9/32 ( 10.0.0.9-fd-fdsb) ( 3123)\n\n"
+ " Destination_address_sets (0):\n"
+ " Source_addresses:\n"
+ " 10.0.0.7/32 ( 10.0.0.7-IR) ( 5989)\n\n"
+ " Applications: tcp3389\n"
+ " Then: permit\n\n"
+ "Policy name: example-4 (lfs-csd) (LINE 29907)\n\n"
+ " Description: CHANGE00002\n"
+ " Destination_addresses (3):\n"
+ " 10.0.0.6/32 ( 10.0.0.1-lk-3r53) ( 3125)\n"
+ " 10.0.0.2/32 ( 10.0.0.8-test13) ( 3157)\n"
+ " 10.0.0.53/32 ( 10.0.0.3-gdgsd-cd) ( 2806)\n"
+ " 10.0.0.94/32 ( 10.0.0.9-fd-fdsb) ( 3123)\n\n"
+ " Destination_address_sets (0):\n"
+ " Source_addresses:\n"
+ " 10.0.0.53/32 ( 10.0.0.52-IR) ( 5989)\n\n"
+ " Applications: tcp53\n"
+ " Then: permit";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}