$re = '/\b[a-zA-Z]{3}\b/';
$str = 'cat monkey dog mouse';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);