# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\\//;t' <<< "\\xxxxx\xxxx\xxx\Companies\test\in\Th FIle Test - Copy - Copy.mp4"