using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[[:alnum:]]+( [[:alnum:]]+)?$";
string input = @"MM56M
MM 54M
MMM 5
555555
LPOLKG
MM 5T YU";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}