re = /^[[:alnum:]]+( [[:alnum:]]+)?$/m
str = 'MM56M
MM 54M
MMM 5
555555
LPOLKG
MM 5T YU'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end