use strict;
my $str = 'Vwo met profiel EM (met Wiskunde B, Natuurkunde & Scheikunde), CM (met Wiskunde B, Natuurkunde & Scheikunde), NG (met Wiskunde B & Natuurkunde), NT.
Vwo met profiel EM (met Scheikunde & Biologie), CM (met Scheikunde & Biologie), NG, NT.
Vwo met profiel EM (met Natuurkunde & Scheikunde), CM (met (Wiskunde A of Wiskunde B) & Natuurkunde & Scheikunde), NG (met Natuurkunde), NT.
Havo met profiel EM, CM (met Economie of M&O), NG (met Economie, een tweede vreemde taal of M&O), NT (met Economie, een tweede vreemde taal of M&O).
Havo met profiel EM, CM (met Economie & (Wiskunde A of Wiskunde B) of M&O en (Wiskunde A of Wiskunde B)), NG (met Economie of M&O), NT (met Economie of M&O).
Havo met profiel EM, CM (met Economie, M&O of Maatschappijwetenschappen), NG (met Economie of M&O), NT (met Economie of M&O).
Vwo met profiel EM, CM (met Economie, M&O of Maatschappijwetenschappen), NG (met Economie of M&O), NT (met Economie of M&O).
Havo met profiel EM, CM (met Wiskunde A of Wiskunde B), NG, NT.
Havo met profiel EM, CM (met Economie & (Wiskunde A of Wiskunde B) of M&O en (Wiskunde A of Wiskunde B)), NG (met Economie of M&O), NT.';
my $regex = qr/^(Vwo|Havo) met profiel (.*?)\.?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}