use strict;
my $str = 'AAAA1
AAA11
AA111AA
A1111
AAAAA1
AAAA1
AAAA1111
A1A1A';
my $regex = qr/^(?=.{2,5}$)[A-Z]{1,4}[0-9]{1,4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}