using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?is)<img(?(?=[^>]* alt=""([^""]+)"")).*?>";
string substitution = @"$1";
string input = @"a <img src=""./dir/file.png"" id=""f"" alt=""flying dogs""> b";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}