# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[ \S]+?SMTP connection from \S+? \(TCP\/IP connection count = (?!\b1\b|\b2\b|\b3\b)\d+\)"
test_str = ("2014-11-27 17:09:05 SMTP connection from [42.117.255.244] (TCP/IP connection count = 1)\n\n"
"2014-11-27 17:09:14 SMTP connection from [118.68.249.18] (TCP/IP connection count = 2)\n\n"
"2014-11-27 17:09:15 SMTP connection from [113.188.85.220] (TCP/IP connection count = 3)\n\n"
"2014-11-27 17:09:15 SMTP connection from [113.188.85.220] (TCP/IP connection count = 5)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.