$re = '/^(?!\babc:\b|\bdefg:\b).*$/m';
$str = 'abc:sadasd
defg:asdasdsa
asgdashgdsadas
asdsadasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);