$re = '/(\d+(?:\.\d+))|(\w+)/';
$str = 'custPowerCourse := 11.1,22.2,33.3,44.4,55.5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);