using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"cast([^\n]+\n){0,2}[^\n]*datetime";
string input = @"cast('""+ object.method()+ ""' as datetime
cast('""+
object.method()+ ""' as datetime
cast('""+
object.method()+ ""'
as datetime
cast('
""+ object.method()+ ""'
as
datetime
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}