$re = '/cast([^\n]+\n){0,2}[^\n]*datetime/';
$str = 'cast(\'"+ object.method()+ "\' as datetime
cast(\'"+
object.method()+ "\' as datetime
cast(\'"+
object.method()+ "\'
as datetime
cast(\'
"+ object.method()+ "\'
as
datetime
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);