addressthe literal text address (case sensitive) \s*any whitespace character, repeated any number of times
\d+a digit, repeated at least once
\s*any whitespace character, repeated any number of times
rangethe literal text range (case sensitive) \sany whitespace character
Group srcIp1(?<srcIp1>\S+) \S+any non-whitespace character, repeated at least once
\s*any whitespace character, repeated any number of times
Group srcIp2(?<srcIp2>\S+) \S+any non-whitespace character, repeated at least once
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string