#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)public\.(?!(bg|cp)_)[^_]+_.*"
Local $sString = "public.bg_table1" & @CRLF & _
"public.bg_table2" & @CRLF & _
"public.cp_table1" & @CRLF & _
"public.my_table1" & @CRLF & _
"public.user_action" & @CRLF & _
"public.cp1_table1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")