package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Warning-\[ABC\] blablabla(\$|\n)*\s+\/path1.*`)
var str = `Warning-[ABC] blablabla
/path1/path2/path3/file`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}